Jump to content
  • Announcements

    • Nahash5150

      All Members Read this!   02/24/18

      Welcome to the NEW CarverSite! If this is your first time logging in, and you were a member of the old site, please go to the top right and click 'existing user'. Click on 'forgot password' and enter the email you used to register on the old site. You will receive a confirmation email. Click on the link and follow the instructions. Enter your password and you should be all set. Please contact me if you have any problems at Nahash5150@gmail.com   Click on the icon in the far upper right corner after you are logged in and go to your profile. Update your avatar and cover photo if you wish. Please also visit the 'account settings' and go to your Signature and correct any dead space or pictures. You are allowed up to 4 lines of text, including a 100x500 picture.      

m-1.5t going in protection mode

Recommended Posts

hi all 
    just started having problems the other day when i turn the amp on after about 5 min went in protection mode for about 1-2 sec meter lights dim this will happen 4 to 5 times in about 20 min than all is good for at least 10 hrs done playing music by than i can push it hard no problem so the next day i started it up but with out the pre amp on same thing it seams when it "warms up"it plays great both capacitor up grads sold by circuitsandconcepts wear in stalled about 6 mo ago any ideas thanks all Rob

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.