Jump to content
Nahash5150

**Carversite UPDATE**

Recommended Posts

Okay, so I didn't complete the update yesterday because this new update is going to break some of our customizations. It's much more extensive than the norm, so I have to do some research, backup some files, updates some applications first, then do the engine update.

 

Some useful new features and changes are a part of it, so I'll list these later. 

 

I'm going to work on the appearance things first, so if stuff gets weird, that is why.

 

If you have any trouble or get errors, please let me know.

  • Thank You 13
  • Love this! 1

Share this post


Link to post
Share on other sites

1 hour ago, sea said:

Thank you for all you do, Greg.

+1 to that!

  • Thank You 3

Share this post


Link to post
Share on other sites

Thank you gentlemen!

 

There's a lot that has changed, although many of them may not be important to your typical visiting experience. This is just part 1, I'll post more changes as I filter through them.

 

Here are the relevant upgrade notes (part 1):

 

Major New Features / Enhancements

 

Post Before Registering
Animated GIFs

Global Group formatting (whoohoo!)

New Email Features:
Email Statistics
Email Advertisements
Unfollow Without Logging In



Core

Added setting to display user group formatting in more areas (see 6 New Micro Features).
Added less intrusive browser notification prompt in Notifications menu (see 6 New Micro Features).
Added ability to show sidebar blocks to only certain types of devices (see 6 New Micro Features).
Added ability for club owners to reorder the navigation tabs (see 6 New Micro Features).
Added ability for announcements to be linked to an URL or be a title only (see 6 New Micro Features), improved consistency in how announcements are shown in different areas.
Added a new UI for attachments, showing a box with some information about the file, rather than a plain line (see Turbo charging loading speeds).

 

Removed Features

Removed EmojiOne-style emojis due to licensing issues.
Removed Gravatar support due to privacy concerns and performance issues.

Removed the name of the content (e.g. topic) from the “Next Unread” link which could consume significant server resources on large communities.

 

Then a patch:

 

 

Core
Made several adjustments to HTTP/2 push/preloading to improve overall performance of most requests and resolve minor bugs.
Changed database connector so that a database connection is only established once it is actually needed.
Improved performance of 4.4.0 upgrades for sites with lots of members.
Improved performance of content item and comment sidebar blocks restricted to specific containers.
Improved Post Before Registering to allow the user to remove their submission and email address.
Changed the error message for a failed login the same regardless of the reason for extra security.
Fixed an issue where guest "post before register" submissions may show up in widgets before the guest registers.
Fixed several areas in the suite where images were not "lazy-loaded" as expected.
Fixed link styling in announcement banners making the text difficult to read in some browsers.
Fixed miscellaneous HTML markup errors.
Fixed an issue where users could encounter an error by logging in with a new social account after already associating with a social account.
Fixed Application icon getting lost when the datastore is flushed.
Fixed an issue where the newsletter signup block was showing an error to guests.
Fixed an issue with button spacing on mobile.
Fixed an issue where streams may go missing if a guest member object is deleted.
Fixed an issue where pagination may not work when 'rewrite FURLs' is not enabled.
Fixed posts not retaining code syntax highlighting with some code languages.
Fixed an issue where private conversations can be very slow to search.
Fixed an issue with the Emoji shortcode popup when lazy load and Twitter Emoji are used.
Fixed an issue with the setting for "Users can see records posted by other users" not being honored.
Fixed an edge case issue where it was possible for the lazy load rebuild to affect embedded videos.

Forums

Improved performance of the post feed widget.

Pages

Fixed an issue where reciprocal "back links" may be incorrectly deleted from records.

Gallery

Fixed an issue where notifications for new images can send indefinitely.

Downloads

Fixed an issue where notifications for new files can send indefinitely.

 

  • Thank You 9

Share this post


Link to post
Share on other sites

Good grief, man, you've been busy!!!!   When was the last decade you bothered to sleep?!?!

 

THANK YOU for everything you're doing - nothing short of incredible work!

Share this post


Link to post
Share on other sites

1 hour ago, Brian_at_HHH said:

Good grief, man, you've been busy!!!!   When was the last decade you bothered to sleep?!?!

 

THANK YOU for everything you're doing - nothing short of incredible work!

 

Oh I didn't actually DO the code, just conveying what the patch covered.

  • Thank You 2

Share this post


Link to post
Share on other sites

1 minute ago, Nahash5150 said:

Oh I didn't actually DO the code, just conveying what the patch covered.

 

Just getting that into place and checking that things work is a long way from trivial - especially with the various customizations that I know you've added over time.  You still have my admiration for it, and I still wonder if/when you ever sleep.  :)

  • Thank You 2

Share this post


Link to post
Share on other sites

1 hour ago, Rod H said:

FYI when not signed in - using Win7/Chrome - scrolling in any thread is really jumpy. 

When signed in it happens on profile pages as well. 

 

One of the new features is 'lazy loading' which is supposed to save on resources - should work similar to other social media sites such that, gifs don't play, large pics don't load, until your screen actually views them. Otherwise, I did some browsing logged in and logged out and didn't notice anything way out of whack on my end.

  • Thank You 1
  • That Rocks 1

Share this post


Link to post
Share on other sites

I am having trouble with the old links. If you visit a post and use a link from the old site (anything with the root "http://www.thecarversite.com/yetanotherforum/default.aspx") it may not work for the time being.

 

Just want to let you all know I am aware of it and I'm working on it. I don't think this was the result of the upgrade, something else happened.

 

Got phone calls to make!

  • Thank You 4

Share this post


Link to post
Share on other sites

21 minutes ago, RichP714 said:

php must have a replace function like MSSQL has?

 

The engine has rules that are supposed to be executed by IIS under URL Rewrite (htaccess on a LAMP), however, the engine has to be aware of this, and it appears that awareness is cut somewhere.

  • Thank You 2

Share this post


Link to post
Share on other sites

1 hour ago, Nahash5150 said:

 

The engine has rules that are supposed to be executed by IIS under URL Rewrite (htaccess on a LAMP), however, the engine has to be aware of this, and it appears that awareness is cut somewhere.

 

can the raw database be manipulated with something like wamp?

Share this post


Link to post
Share on other sites

53 minutes ago, Nahash5150 said:

 

I don't know. And if it could, I wouldn't know how to do it. 😕

 

I think a permanent solution is best though. 

 

Groovy; wamp isn't intractable though.  I had a similar situation when migrating a wordpress blog to another domain and subdomain; wamp worked great to re-write the existing db entries' pathnames; wordpress itself took care of things after that 

Share this post


Link to post
Share on other sites

On 3/15/2019 at 9:13 PM, RichP714 said:

 

Groovy; wamp isn't intractable though.  I had a similar situation when migrating a wordpress blog to another domain and subdomain; wamp worked great to re-write the existing db entries' pathnames; wordpress itself took care of things after that 

 

I'll discuss with my dev and see what he thinks...the conversion was fairly complex from the start, and custom made so we could carry over just about everything.

 

Anyway, looks like the latest core update actually did break the converter. Time for some meetings again...

  • Thank You 3

Share this post


Link to post
Share on other sites

Addendum:

 

More new features...

 

Sound Rooms - owners can reorder their feature menu tabs for a more custom experience.

 

Announcements - we don't use these often, but I can now customize them so they appear in a variety of places to get your attention. tehehe...

 

Group Formatting - I'm sure you've noticed that user names are retaining their Group Color like the old site did - super cool. I'm so glad we can do that now without getting in the weeds of the code.

 

Device Customization - I can now hide certain widgets from phones and tablets or PC browsers. This means I could show the chatbox only for PC users, and hide it on phones or tablets, or visa versa. I don't see any need for this kind of customization, but we can do it if certain things are too annoying on certain platforms. Then again, it might be useful to hide the chatbox on the main page for phones, but they could still view it on the Chatbox Tab instead.

 

  • Thank You 6
  • That Rocks 1

Share this post


Link to post
Share on other sites

3 hours ago, Nahash5150 said:

I have more updating to do to fix the errors the previous updating created...

 

Don't you mean that there aren't enough "features," (aka bugs, errors, and glitches) so you need to add more in to achieve the proper quota of issues?

 

Good luck!

Share this post


Link to post
Share on other sites

15 hours ago, Brian_at_HHH said:

 

Don't you mean that there aren't enough "features," (aka bugs, errors, and glitches) so you need to add more in to achieve the proper quota of issues?

 

Good luck!

 

Exactly!

 

Patch is patched. Here are more Release Notes:

 

Core


Upgraded CKEditor to 4.11.3.

Adjusted search results processing to automatically clear out invalid results when detected.
Adjusted comment and item widgets to restrict by the last year to prevent slow performance.
Fixed an issue where the leaderboard may not correctly rebuild.
Fixed an issue where searched terms may not be highlighted on the search results page when using Elasticsearch.
Fixed being unable to reach the last page of search results with Elasticsearch.
Fixed an issue where users could encounter an error by logging in with a new social account after already associating with a social account.
Fixed mobile PWA manifest file not being accessible to guests when guests are required to login to use the site.
Fixed an issue where javascript would not load due to a bug in the 3rd party Howler library.
Fixed an issue where the prune members background task may stall if it encounters a staff account.
Fixed an issue where email link tracking may not apply to all bulk mails sent.
Fixed an edge case issue where it was possible for the lazy load rebuild to affect embedded videos.
Fixed an upgrade issue that can occur if you have more than one of the same email address specified for upgrade notifications.
Fixed an issue where imported members accounts were not marked as completed.
Fixed an issue where changing the warning type on the warning form would not toggle the 'remove points never' checkbox to the correct value
Fixed an issue where profile fields display HTML code when applying custom formatting.
Fixed an issue where the display name filter wouldn't store the "either" option.
Fixed images with uppercase extensions not launching the lightbox correctly.
Fixed an issue with comment widgets where editing them may not show the correctly selected date range.


Core REST API

Fixed an error adding a member to a club through the REST API.


Forums

Excluded archived topics from email digests.
Fixed an issue where post counts for forums may be incorrect if archiving is used.
Fixed an issue where merging two topics may show the topic at the wrong position in the forum listing.
Prevented a possible infinite redirect problem when merging two topics simultaneously with each other.
Applied group name formatting to member names in topics when viewed on a phone.
Removed redirect forums from fluid view.


Gallery

Fixed an error upgrading Gallery when there are orphaned albums.

  • Thank You 4
  • That Rocks 1

Share this post


Link to post
Share on other sites

UPDATE:

 

It was reported to me that some topics disappeared from the Featured Topic feed and the Recently Posted In feed. I found that the topics that disappeared were started over a year ago, and the forum application update included, by default, that the feeds only display 'in the last year'. I changed it so that the feeds shouldn't care when a topic was started, so, let's see if that works...

  • Thank You 4

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...