Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

SRGresham

Novice
  • Content Count

    50
  • Joined

  • Last visited

  • Days Won

    1

SRGresham last won the day on December 17 2020

SRGresham had the most liked content!

Community Reputation

80 Excellent

About SRGresham

  • Rank
    5W Resistor
  • Birthday August 22

Personal Information

  • Location
    Oakhurst, CA/Fresno, CA
  • RealName
    Steve Tech/Gresham
  • Occupation
    Network Administrator, Mechanic

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Here you go, it's only money. ๐Ÿ™‚ https://www.audiogon.com/listings/lisa6g27-degritter-ultrasonic-record-cleaner-cleaning-systems
  2. I started a thread in amp repair to continue my TFM-45 project (debacle).๐Ÿ™ƒ
  3. I almost feel like I know most of you from the posts I've read. I recognize all the names that have posted in this thread so far. ๐Ÿ˜€
  4. Yes, I can see it in all the posts I've been reading. I've read almost all the technical posts back to 2014. ๐Ÿ™„
  5. Yeah, I forgot to mention the TX-12 tuner, too. ๐Ÿ™‚
  6. I haven't gotton that far yet. The high rail is about 60v and the others are about half of what's expected. I've only spent about a half hour on the amp so far.
  7. Thanks! The amp is at work so I won't be able to take a picture until Monday. I knew something was up before I took the top off when I saw a big blue cap through the grille. The caps on the power supply board also are no longer glued to the bottom of the chassis and the amp boards were popped out of the molex connectors bowing the power supply board. After resetting the boards in the connectors I slowly brought op the AC power to 120v to see if the fuse would blow or something would smoke. Nothing happened so I measured the rail voltages which were about half of what they should have been. I p
  8. I really want to upload a picture of the big power supply caps. There is a 4500ยตF zip tied and connected on top of the two original 9000ยตF caps. Does that even work? ๐Ÿ™‚
  9. Hi all! After lurking here and reading many threads, it's time to say hello. I bought my Carver system new in 1984 and ran it up until a few years ago when it started to have some issues. I have an M1.5t amp, C-1 preamp and a TX-11 tuner attached to a pair of Celestion SL6 speakers. Most of the problems were caused by dirty switches and pots on the C-1 which were taken care of with DeoxIT which seems to be a lot better than the regular contact cleaner I've used in the past. The sound quality has definitely deteriorated since it was new and I joined this forum to get ideas on repaired and upgra
ร—
ร—
  • Create New...