Jump to content

New Member trying to post on the welcome page


Recommended Posts

Just joined and was approved. The message I received stated that I need to post on the welcome page and receive 4 or more replies before I can post. There are no links on the text area of the welcome page. Can someone point me the right direction? I have three Carver components that need help, or I may just need to find them a new home. Please point me in the right direction.

  • Thank You 6
Link to comment
Share on other sites

Here is my intro...

I am a retired long time audio enthusiast with around 50 years of experience in audio. I worked for the last 35 years in marketing and technical documentation for an audio manufacturer dominant in the TV broadcast, motion picture and installed sound markets. I have a C-1 preamp, M1.5t power amp and TX-11 FM tuner that I not longer need. The preamp and power amp need some repair. Post here or PM me at opusstuf@gmail.com for more details.

  • Thank You 6
Link to comment
Share on other sites

Welcome @opusstuf.  That C-1 and m1.5t are beloved components...

 

I'm not a tech, but it would be helpful if you shared what the issues are that you may need help with?  Symptoms, what happened when they stopped working, how long since they worked last..., anything helpful will get more tech-minded members thinking on solutions.

 

Again, welcome!  Glad you found us!

Link to comment
Share on other sites

Welcome!

 

Posting the issues you are having as @AndrewJohn suggested is a great start. Both of those pieces of equipment are well worth the time to get them up and running.

 

If I may give a suggestion, look at these links as I think they will give some ideas:

Carver M-1.5t mkII, Restore and Upgrade - Carver Amplifiers - Nelion Audio

Carver C-1/C-11 Restore - Carver Preamplifiers - Nelion Audio

Carver C-1/C-11 Restore with Bill D Mod - Carver Preamplifiers - Nelion Audio

The repairs/restorations are done by @Nahash5150 He is an Administrator for this site, and I had three amps restored by him and well worth it.

 

Also sounds like you have other equipment. I'm sure others would like to know what it is.

 

Enjoy the site!

 

Link to comment
Share on other sites

@opusstuf

 

There is a message at the top of the main page that reads like this:

 

Welcome to TheCarversite! Please take a moment to introduce yourself HERE. Start a topic by clicking on the 'Start Topic' button at the top right of the screen when you arrive at the Welcome Shop. You must rank up to Novice before you can post pictures or download certain content. You will rank up after you receive over 5 positive reactions to your post. Don't worry - it's easy!

 

- Administration

 

So if you click on the HERE it takes you to the Welcome Shop Forum (where this topic currently is). As explained above, you can post all you want, but you have to be a Novice Rank to post pictures or downloads.

 

Link to comment
Share on other sites

Thanks to all for the replies. Still puzzling why the links (HERE) didn't work.

The issue with the C-1 preamp is an extremely loud pop in the audio output when the power is turned off. Only happened once, which freaked me out because I was afraid it took out my Tannoy System 15 monitors. This was 3 or 4 years ago. Have been using a Crown Straight Line 2 preamp since then.
The M1.5t power amp just quit delivering audio a few months after the POP problem with the preamp. Instead of audio, it outputs fairly loud 60Hz hum with a HF buzz mixed in. It was working one day, then the problem was present the next day when I turned it on. I am now using a matrix DSP processor made by my previous employer for crossover feeding two Onkyo power amps to biamp the Tannoy System 15 speakers.

I could post a complete description of my entire setup, but most of you would probably laugh. Might be worth a chuckle. I have two separate systems that feed each other back and forth - a stereo system with the Crown preamp and biamped Tannoys mentioned above, and an Onkyo based 7.1 surround system. After finally getting all the delays close to right, it's very entertaining in my 17 by 34 foot listening room that has only two parallel walls and vaulted ceiling.

I have recently finished my MTM concept speakers that I will try in the front L-R positions in the 7.1 surround system. Initial listening to some 24-bit digitized copies of 80's era direct to disk vinyl is "gratifying" given the amount of time I have invested in the design and build of the MTMs.

I could ramble on, but have things to do. I would very much appreciate a wild guess from Nahash5150 regarding the cost of restoring the C-1 and M1.5t components.

  • Thank You 1
Link to comment
Share on other sites

2 hours ago, opusstuf said:

Thanks to all for the replies. Still puzzling why the links (HERE) didn't work.

 

I'm sorry - I don't see any trouble whatsoever with the links. Inbounds can click on the HERE link on the mainpage and be brought right to the Welcome Forum. But now you're a Novice, so you pretty much have access to everything and can post pictures.

 

2 hours ago, opusstuf said:

I could ramble on, but have things to do. I would very much appreciate a wild guess from Nahash5150 regarding the cost of restoring the C-1 and M1.5t components.

 

No need to guess - all the details are on the Nelion Audio website.

 

M1.5t restore and mkII upgrade

C-1 restore and BillD upgrade

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...